Axis 0 moves violently when hpu is started

Any advice on where/what to look for. I put a new valve on axis 0, and upon powering hpu, it did the normal “air in line dance,” then smoothed to what appeared to be normal motion.

Yesterday I was informed that when starting the hpu, axis 0 jumped forward. They shut off hydraulics and restarted. Axis did not jump.

This system is a SLC 5/03 telling a RMC100 where axis needs to be. When hpu is started, we send initialization values to rmc, then tell it to go to the last commanded location. On shutdown, we just issue a halt command to lock the axis in place.

I am at a loss here, as I know next to nothing about motion.


Hi Swed,

It sounds like they may have been in closed loop control when the HPU was turned on. In most cases we want to be in open loop control to avoid those jumps at the start. If we don’t have control of the system and we are given a target the integral gain will continue to wind up until your output is very high and the valve is completely open, this in-turn could cause the jump you’re seeing.

The best way to see if you’re in open loop is, clicking on your status bits:

And then looking at the “Open Loop” bit, we’d expect this to be on when the HPU powers up:

Let us know how it goes!

So, if I understand you correctly, I should be in open loop control when the hydraulics are off? Here is what I found when I connected to the controller after the shift ended and hydraulics were off. Is there some sort of best practice that I should be following? I didn’tmake this machine, I only inherited the problems. Thanks for the help so far! 20210202_162730|560x500

Hi Swed,

Correct, we would expect you to be in open loop when the hydraulics are off, it looks like from the provided image your system is staying in closed loop control. Always fun inheriting problems :wink: There are a few options you have as far as best practice for shutting down. In some cases the controllers themselves are powered off, in others all the axes are stopped using the “K” command. This would most likely be the easiest route to take. You could also issue an open loop “O” command to each of your axes with a voltage of 0. If your SLC 5/03 controlling the system knows when the HPU goes off it would most likely be best to place some shutdown logic in the PLC to send commands over to the RMC.

While extremely helpful, I find myself with more questions. I think I may have tried issuing a “k” command back when the issue started, but had drifting on axis 0. Would that be indicative of a deadband issue? On starting the hpu, do I need to send initialization values to the controller, or should I save them to flash and just send closed loop as well as command position and speed? Then at shutdown, send open loop and 0 volts? I may not have parameters straight in my head.

I will talk this over with the boss tomorrow, and depending on any other information you can give me, as well as myself reading the full instruction set, make a plan to improve this house of horrors.

Thanks again, I’ll be sure to follow-up with any changes I make and the results I see.

The drifting you’re seeing could be due to deadband or null offset. Here a link to our Null Drive help topic.

I’m not sure how your process is running right now, there are many things that could change the startup procedure, but generally startup and shutdown should look like this:


  1. Controller powered on in open loop, 0 volts output.
  2. HPU turned on, you might see a slight drift in this stage if the null drive hasn’t been set.
  3. RMC set to closed loop control, holding position.
  4. Ready to start event steps or user program


  1. RMC in closed loop control holding position or stopped
  2. RMC goes into open loop 0 volts, might see slight drift here
  3. HPU shut off

I have official authorization to change the program and get this machine working how it should, but the machine won’t be out of production until next week.

How important is tuning the drive and setting null offset and deadband? I assume very important, but, as I’ve said, I’m not a motion guy, just a controls guy trying to make things work.

While looking through the docs today, I noticed that rmcwin allows putting in a gradient for a tempo, I don’t know if that is based on firmware versions or not. As far as I can tell, that was never done on this machine. I also don’t know what my current f/w version is. I’ll be looking at that tomorrow when shutdown happens…

Based on my timeset, I assume I’ll be able to get this fixed the proper way.

Is there any way I can contact you outside this forum if I have questions?

Hi Swed,

Glad to hear!

Just as you’ve said, tuning the drive is very important and the first thing you want to do to achieve good results. If the drive isn’t tuned well no amount of tuning on the RMC will produce great results.

The gradient is very important to calculating your position units. For an MDT, PWM or Start/Stop you’ll input the gradient by going to tools > MDT Scale/Offset Calibration.
image image

Feel free to email me at or give me a call on our main line (360)702-0178 and ask for David McNichol. We are always happy to help!