Labview RMC75e communications problem

I’m just playing around here with Labview 2012 32bit and Windows 7 64bit and a RMC75e. I’ve got the drivers for the RMC75 installed in labview and the libraries are all available. I’m using “Set Discrete Output” to try turning on one of the digital outputs.

The computer is hooked up to the RMC75 through ethernet.

I’m not sure if I should be using modbus or rmclink for the communication method, but I have had much better luck with modbus. I have been able to modify outputs using that method.
In fact it seems to work perfectly as long as I run the VI once. When I run it continually (either in a loop or running the vi continually) in modbus mode, it throws a out of memory error 56 that you can see in the modbus error attachment saying the network operation exceeded the user specified or system time limit.

When I switch to RMCLink, I get the error in that attachment right away. I can’t get anywhere with that. It says RMCLink isnt installed, but it is. I tried uninstalling and re installing as well.

Any help or direction would be appreciated

Thank you


The error that you are getting when running the loop is from being called too many times without closing the connection. If you do not close the connection (with exactly once for each time you call, the connection will eventually time out and close itself but doing that too much will cause problems.

Instead of initializing the connection each time through the loop, call only once before entering the loop and then you can use the reference to set the discrete output as often as you want. When the loop exits, be sure to call