Limit Inputs


It is the first time I work with positive and negative limit inputs (with Quad Module) and I would like to know if I do it right.

I configured the parameters to be sure the motion stops if we reach the positive limit input (PLIM) or the negative limit input (NLIM). So, in normal operation, if we reach one of these limits the enable output is turned off for more safety.

With this configuration, I got a issue during homing sequence. Here are the steps of our homing sequence :

  • Set current position to the negative travel limit (To avoid reaching the positive travel limit in the subsequent move).
  • Set Enable Output to enable.
  • Move Relative with a distance to be sure we pass over the HOME switch. (When the move is done or we reach the PLIM we continue)
  • Change the AutoStop Config for the positive limit input to “Status Only”
  • Clear Faults
  • Set Enable Output to enable.
  • Arm Home
  • Move Relative with a distance to be sure we pass over the HOME switch again. (When the home is done we continue)
  • Change back the AutoStop Config for the positive limit input to “Direct Output Halt”

I don’t like the idea of changing the AutoStop Config for the PLIM during the homing sequence… But this is the only way I found to move back when we have reached the PLIM.
Do you have better idea ?

You may already work with something similar. How did you manage it ?

Finally, with my small experience with motion controller, I wonder about some details.

  • Why a Limit Input stops movement in both direction (for linear axis of course). If I reached the PLIM, there is no reason stopping a negative movement.
  • It is ok to have a command to turn on or off the Enable Output. But according to me, every “motion” command should turn it on automatically.


According to this RMCTools help topic, in the Issuing Commands while a Limit Input is Active section, you should be able to send a closed loop command to move the axis back to the valid travel range, even if the Positive Limit Input is on. Is it not working correctly?

There are many situations where it is very good to have a specific Enable Output command. For example, if several devices are sending motion commands to the RMC, and are not polling whether to see if an error exists, then a specific command is important in order to prevent undesired attempts at motion.

If you don’t want the Enable Output to turn off when an error occurs, you can make sure that none of the AutoStops are set to Direct Output.

I have to say I have been through this help topic… I remember the pictures for good and bad practice… but I didn’t read the 2 sections that would interested my case :blush:

You make me realize… at first, all tasks were stopped by any axis halts… I might have been confused by that… :blush:

I will keep working on that…

Thanks for you help !