Problem with Indirect Data Map Editor

Good day all!
I have small problem with Indirect Data Map Editor.
In the Variable Table I made variable with name STATE_DELTA_MAIN (DWORD)

And in the Indirect Data Map Editor I made reference on this variable (for exchange data via Profibus)

It is working. But if I set in variable STATE_DELTA_MAIN bit 31 in true, data not refresh in the Indirect Data Map Editor.
If i removed this bit all works again.

All pictures in attachments.

May be somebody has similar problem?
I will glad if you help me.

I was able to duplicate the problem. We will fix it immediately, and the fix will appear in the next firmware release, which is expected to be done today or early next week.

Thank you for reporting the problem!

Thank you for your fast answer.
Today I downloaded firmare for the RMC75P ( Version: 3.53.0Date: 12/7/2012Size: 2.2 MBType: BIN file) and updated my PLC, but problem remained.
Can you check this problem again, please.

It turns out the problem was in RMCTools, so you will need to download the new version of RMCTools.

Today I installed new RMCTools (Version: 3.53.0Date: 12/7/2012Size: 14.8 MB).
But problem remained.

I have value C001B286 before and when I set 31 bit I recieved value 80000000. And this value not changing while bit 31 in TRUE.
May be I make something wrong?

There was indeed a problem that we fixed. How are you writing to the bit? The RMC does not really support individual bit writes, you can onyl write to the whole register. To write to an individual bit, you need to read the entire register, change the bit in the data you read, then write the register back. IT sounds like you are writing the entire register. What device are you writing from?

I can try explain how we made.
On the first picture you can see situation when we have value 16#C000025A in variable STATE_DELTA_MAIN in “Variable Table”. We can change this value by column “Current”. We can set or remove any bit in DWORD. When we changed bit, we press button “Download to controller”.

On the second picture we can see that we removed one bit (16#8000025A in variable STATE_DELTA_MAIN) and value changed in “Variable Table” but in the “Indirect Data Map” value remains 16#80000000, and not changed. If we set other value for example 16#8000235B in “Variable Table” we get in “Indirect Data Map” the same value 16#80000000.

On the third screen you can see firmware version CPU and RMCTools.

Hmmmm, I am not able to reproduce it. When this happens, does it make any difference if you close, then re-open the Indirect Data Editor?

Today I tried repeat experiment on other computer. I tried open and close Indirect Data Map, open and close RMCTools. Problem remained without changes.

This problem has now been fixed in firmware version 3.53.1.

Thank you for your help. In new version all works.